Another trip minder snafu

Discussion of STOCK TripMinder®, audio, video, LED, capacitors, instrument clusters and controls, integrated circuitry and boards, low voltage, message center, resistors, speedometers, tachometers, transistors and systems.

Another trip minder snafu

Postby MashmyMotor » Sun Jul 26, 2015 3:00 pm

AARRGGGHHH! :shock: This car is going to drive me to drink! :twisted:

I just got my right rear brake sorted out..seems to work fine.

I started the car to go check it out and my trip minder was reading odd. It showed the correct time and below instead of showing day and date..it showed I was getting 43 mpg :roll:

So I reset everything..proper time etc and took a ride. about 5 minutes into the ride the TM beeped and showed ETA ---
then beeped again and showed DTE 9999..I pushed the clock button and got the time back..a short while more beeps and ETA with clock count down..reset again...worked fine for a bit..then beep beep beep...ETA----
What gives? Worked fine before I fiddled with the brake :geek:

Jim
User avatar
MashmyMotor
REGISTERED USER
 
Posts: 62
Joined: Sun Oct 19, 2014 12:40 am

Re: Another trip minder snafu

Postby K MANIAC » Sun Jul 26, 2015 3:49 pm

Jim:

Have you inspected and/or replaced the ignition switch in your car? Sounds like a failing ignition switch issue. Read...

http://thelincolnmarkviiclub.org/docume ... Switch.pdf
http://thelincolnmarkviiclub.org/docume ... Switch.pdf
"This car may be old, but it will still climb Kirker Pass at 110!"- quote of the original owner of my green 1964 Chrysler 300-K

Image
Image
1986 Continental
1989 Mark VII Bill Blass (Oxford White)
1989 Mark VII LSC (Pewter Metallic)
1989 Mark VII LSC (Sandstone Metallic)
1/2 of a 1992 Town Car Signature (my guaranteed inheritance)
K MANIAC
BOARD MEMBER
 
Posts: 2323
Joined: Sat Dec 27, 2008 10:47 am
Location: Concord, California

Re: Another trip minder snafu

Postby Dv3andrs » Thu Mar 02, 2017 9:37 pm

I apologize for reviving an old thread, but i'm sporting an 88 LSC and i'm having all sorts of random electrical issues with it. Car has 24k on it, got it from my youngest brother. The trip computer/minder is consistently innacurate, will say I have 500 miles till empty, then sets an alarm off 5 miles later saying I have 35 till empty, speedo bounces while stopped, gas gauge is extremely off, full pegs the needle so you can't see it, and the last time I ran out of fuel, I had a little over a quarter tank. The engine temp doesn't register either. There might be more i'm forgetting or not noticing at this point. I got the car from him a month ago, just had the transmission fully rebuilt as well. This is the 4th post i've read that references this ignition switch, is there a diagram posted somewhere that shows everything that goes through it, and does it sound like a possible culprit to some of the random issues i'm experiencing?
1988 Mark VII, LSC, 24k original miles.
No mods, 5.0liter, air ride.
User avatar
Dv3andrs
REGISTERED USER
 
Posts: 5
Joined: Wed Feb 22, 2017 11:59 am
Location: Fort Walton Beach, Fl

Re: Another trip minder snafu

Postby 2manymarks » Sat Mar 04, 2017 9:02 am

Dv3andrs wrote:I apologize for reviving an old thread, but i'm sporting an 88 LSC and i'm having all sorts of random electrical issues with it. Car has 24k on it, got it from my youngest brother. The trip computer/minder is consistently innacurate, will say I have 500 miles till empty, then sets an alarm off 5 miles later saying I have 35 till empty, speedo bounces while stopped, gas gauge is extremely off, full pegs the needle so you can't see it, and the last time I ran out of fuel, I had a little over a quarter tank. The engine temp doesn't register either. There might be more i'm forgetting or not noticing at this point. I got the car from him a month ago, just had the transmission fully rebuilt as well. This is the 4th post i've read that references this ignition switch, is there a diagram posted somewhere that shows everything that goes through it, and does it sound like a possible culprit to some of the random issues i'm experiencing?



Definitely sounds like a candidate. Do a search for ignition switch and/or check Tech section.
As of July2017, 11 Mark[*] VII's, 3 licensed for the road:
1989 LSC Midnight/Current Red c/c (9G) mostly stock 99k.
1989 LSC Midnight/Current Red c/c (9G) 124k, stock, needs air suspension & bodywork.
1989 Light Titanium c/c (11) Bill Blass - stock. miles unk
1989 LSC Medium Sandalwood (62) Mass air+ 111k FOR SALE $900.
1986 BB (8T) stock 125k (wife'sDD)
1987 BB (4L) stock (miles unk)
1987 Base Model White (9L) 107k (2.73rear)
1984 Turbo Diesel Base model, Platinum (1Q), 131k+ FOR SALE $1000.
Parts cars: 88 LSC, 89 BB, 90 LSC - TLZ 5spd (complete conversion w/extras 4SALE)
User avatar
2manymarks
CLUB MEMBER
 
Posts: 1234
Joined: Sat Dec 27, 2008 4:24 pm
Location: Coastal NC-the Right Coast

Re: Another trip minder snafu

Postby oldschool1 » Thu Mar 23, 2017 1:22 am

If you read this post in PC mode, you can click the IGNITION SWITCH link in my signature.

For those that didn't know, at the bottom of each page, there is a blue button, <Switch to full style> for mobile users to view the full array of features available here in the Club's Forum.

Give it a try and see what you've been missing.
User avatar
oldschool1
CLUB MEMBER
 
Posts: 8773
Joined: Fri Dec 26, 2008 10:01 pm
Location: Primos, Pennsylvania USA

Re: Another trip minder snafu

Postby Dv3andrs » Fri Mar 24, 2017 7:21 pm

Does anybody know if these are case grounded switches? I bought a Duralast one that was for year, make, model, and I slaved it in. Tried the key and get nothing, i'm an electrician by trade on Aircraft, so I have a pretty good understanding of wiring...as long as I have a diagram.
1988 Mark VII, LSC, 24k original miles.
No mods, 5.0liter, air ride.
User avatar
Dv3andrs
REGISTERED USER
 
Posts: 5
Joined: Wed Feb 22, 2017 11:59 am
Location: Fort Walton Beach, Fl

Re: Another trip minder snafu

Postby oldschool1 » Sat Mar 25, 2017 12:42 am

Yes I do and yes they are ... on one of their circuits. There are two other circuits that will ground this unit.

What year Lincoln Mark VII do you have?

Different years have different grounds.
User avatar
oldschool1
CLUB MEMBER
 
Posts: 8773
Joined: Fri Dec 26, 2008 10:01 pm
Location: Primos, Pennsylvania USA

Re: Another trip minder snafu

Postby Dv3andrs » Sat Mar 25, 2017 1:06 pm

It's an 88. I guess i'll go buy the special torx driver and try fully installing it and see what that does.
1988 Mark VII, LSC, 24k original miles.
No mods, 5.0liter, air ride.
User avatar
Dv3andrs
REGISTERED USER
 
Posts: 5
Joined: Wed Feb 22, 2017 11:59 am
Location: Fort Walton Beach, Fl

Re: Another trip minder snafu

Postby oldschool1 » Mon Mar 27, 2017 12:10 am

Yup.
Make sure that ALL connectors are secure.
User avatar
oldschool1
CLUB MEMBER
 
Posts: 8773
Joined: Fri Dec 26, 2008 10:01 pm
Location: Primos, Pennsylvania USA

Re: Another trip minder snafu

Postby Dv3andrs » Wed Apr 12, 2017 6:05 am

Finally got this switch changed out, no change on any of the random dash and trip minder issues. Any other pointers or areas to look towards? The switch I removed looked pretty good as well, not pulling apart anywhere, all wires leading to it look good as well.
1988 Mark VII, LSC, 24k original miles.
No mods, 5.0liter, air ride.
User avatar
Dv3andrs
REGISTERED USER
 
Posts: 5
Joined: Wed Feb 22, 2017 11:59 am
Location: Fort Walton Beach, Fl


Return to Electronic

Who is online

Users browsing this forum: No registered users and 1 guest