In need of help

Alaska, Arizona, California, Hawaii, Idaho, Nevada, Oregon, Utah, Washington

In need of help

Postby josephpadilla.1400@gmail.com » Mon Sep 26, 2016 5:31 pm

My 1990 Lincoln mark7 LDC,pulsates when I start it up .now it's starting to die when I put it in park.I put new plugs and wires and it stopped for a while and it's doing it again.
User avatar
josephpadilla.1400@gmail.com
REGISTERED USER
 
Posts: 2
Joined: Mon Sep 05, 2016 10:39 pm

Re: In need of help

Postby oldschool1 » Mon Sep 26, 2016 7:07 pm

Search here for REPLACED MY IDLE CONTROLLER
User avatar
oldschool1
CLUB MEMBER
 
Posts: 8645
Joined: Fri Dec 26, 2008 10:01 pm
Location: Primos, Pennsylvania USA

Re: In need of help

Postby K MANIAC » Mon Sep 26, 2016 8:51 pm

Welcome from just a few miles south in Concord. Have you checked the operating fuel pressure with a pressure gauge connected to the test port on the fuel rail? In a pinch, I can arrange to make house calls.
"This car may be old, but it will still climb Kirker Pass at 110!"- quote of the original owner of my green 1964 Chrysler 300-K

Image
Image
1986 Continental
1989 Mark VII Bill Blass (Oxford White)
1989 Mark VII LSC (Pewter Metallic)
1989 Mark VII LSC (Sandstone Metallic)
1/2 of a 1992 Town Car Signature (my guaranteed inheritance)
K MANIAC
BOARD MEMBER
 
Posts: 2317
Joined: Sat Dec 27, 2008 10:47 am
Location: Concord, California

Re: In need of help

Postby oldschool1 » Thu Sep 29, 2016 2:59 am

CAR DAY!
User avatar
oldschool1
CLUB MEMBER
 
Posts: 8645
Joined: Fri Dec 26, 2008 10:01 pm
Location: Primos, Pennsylvania USA


Return to Western US

Who is online

Users browsing this forum: No registered users and 1 guest