OEM Radio Install Issue

Discussion of STOCK TripMinderĀ®, audio, video, LED, capacitors, instrument clusters and controls, integrated circuitry and boards, low voltage, message center, resistors, speedometers, tachometers, transistors and systems.

OEM Radio Install Issue

Postby C.K » Sat Sep 24, 2016 2:25 am

When i bought my LSC it came with an aftermarket pioneer head unit matched to the oem premium sound. The previous owner had mentioned that the original hu quit working. Wanting to revert back to oem, I recently picked an 89' grand marquis am/fm/cassette with the toggle volume E8LF i believe is the serial, the non CD changer compatible.

I installed the Merc unit using the mark oem connector and 6 pin to amp. The HU powered on but the volume output was very low, no mid or bass. Everything seems to be hooked up fine, so I'm wondering if the amp isn't functioning properly (maybe the reason for previous owner to think the oem HU was the issue?). The pioneer deck has a harness that connects its speaker outputs to the 6 pin oem amp wire and sound works fine. Im wondering if there could be an amp bypass in the trunk that was installed, and maybe just the pioneer internal amp is running the speakers now. Im just not sure how the bypass works or what to look for if there is one.

Other thing...Along with the mark oem connector there is a thicker red wire on its own that was connected to the aftermarket harness as a ground. Now that I've taken out the harness I'm not sure where is red ground normally connects. When testing the merc HU i just had the red wire touching a metal bracket inside the dash.

much appreciated!
User avatar
Posts: 1
Joined: Wed Sep 21, 2016 4:24 pm
Location: Winnipeg

Re: OEM Radio Install Issue

Postby WHITEOXLSC » Mon Oct 10, 2016 3:44 pm

It is possible that the installer of the pioneer unit also bypassed the amp in the trunk using a bypass connector. This allowed the Pioneer HU to power the speakers without the use of the JBL amp. Common practice if the HU had a high power amp built in. The radio you got needs the amp and will not power the speakers itself. Check in the trunk to see if indeed the amp is connected and not bypassed 8-) ......

1990 Regatta Blue LSC (newest addition aka Blu)
1986 Mark VII Silver LSC (sold, aka the Grey Ghost)
1990 Mark VII Oxford White LSC (new addition aka the WhiteOx)
1993 Ford Green Explorer Sport 2WD 4.0L V6 (daily driver do everything truck)(loaded first generation)
1988 Ford Blue/mostly rust brown Ranger 2.9L V6 STX P/U (Old faithful) (dead trans, 358XXX miles, sold)
1975 Oldsmobile Blue Omega Hatchback Coupe

Proudly supporting ; Pick N Pull of the greater bay area, NAPA auto parts, Ebay, Suncore Industries, Johnny Franklin mufflers, and Paul Protos electronics restoration.
User avatar
Posts: 1207
Joined: Sat Oct 12, 2013 12:44 pm
Location: Santa Rosa, Sonoma County (the "other" wine country) California

Re: OEM Radio Install Issue

Postby phoenix » Sun Jan 22, 2017 2:51 pm

Hey Connor,

You have PM.
Image Image

1990 LSC SE (a.k.a. "Christine")
1991 LSC (a.k.a. "Ghost")

Christine: Arnott air springs/front, Suncore air springs/rear, CHE rear control arms, 1.5/16" front "Turbo Coupe" bar, Addco 415 rear bar, poly bushings everywhere, 1x2" SF connectors, MM caster plates, KYB shocks, Michelin Defenders, special order factory built Turbo Coupe color scheme cloth LSC buckets (with a matching backseat), factory CD/JBL (resto: Paul Protos)

Ghost: factory air springs, everything stock (except the front buckets out of '88 XR7), factory cassette/JBL (resto: Paul Protos)

latest 3 projects: brake accumulator/system flush (Ghost), rear calipers (Ghost), ignition coil (Ghost)
User avatar
Posts: 2746
Joined: Wed Apr 21, 2010 11:12 pm
Location: Chicago

OEM Radio Install Issue

Postby JamesDiand » Sat Sep 23, 2017 4:51 pm

Does anybody know the factory radio diagram or where i could find one for FREE on the internet? please help
User avatar
Posts: 1
Joined: Sat Sep 23, 2017 12:59 am
Location: Bahrain

Return to Electronic

Who is online

Users browsing this forum: Google [Bot] and 1 guest